probleme avec phpmyadmin

Questions sur le développement PHP.

Modérateur : Modérateurs

Celeborn
Nouveau membre
Messages : 2
Inscription : dim. 28 janv. 2007, 0:48

probleme avec phpmyadmin

Messagepar Celeborn » dim. 28 janv. 2007, 0:53

salut a tous,
j'ai installé le programme Wamp5 qui permet d'installer a la fois Apache, MySql, php et phpmyadmin, mais voila, quand je veux lancer la page phpmyadmin, mon navigateur me met une page d'erreur :

"phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de "host", "username" et "password" dans config.inc.php et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.

Erreur

MySQL a répondu:Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO) "


j'ai regardé un peu le fichier config.inc.php mais j'ai préféré ne pas y toucher et venir demander ici.

Merci d'avance pr votre aide, a+ ;)

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » dim. 28 janv. 2007, 9:05

Sans connaître la configuration des serveurs... impossible de savoir ce qu'il en est ;)
Demandez au support de WAMP, ou installez manuellement les différents serveurs

Avatar de l’utilisateur
dexmon
Gourou
Gourou
Messages : 793
Inscription : sam. 18 juin 2005, 9:55
Localisation : /usr/local/apache
Contact :

Re: probleme avec phpmyadmin

Messagepar dexmon » dim. 28 janv. 2007, 13:00

Celeborn a écrit :salut a tous,
j'ai installé le programme Wamp5 qui permet d'installer a la fois Apache, MySql, php et phpmyadmin, mais voila, quand je veux lancer la page phpmyadmin, mon navigateur me met une page d'erreur :

"phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de "host", "username" et "password" dans config.inc.php et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.

Erreur

MySQL a répondu:Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO) "


j'ai regardé un peu le fichier config.inc.php mais j'ai préféré ne pas y toucher et venir demander ici.

Merci d'avance pr votre aide, a+ ;)


Salut,
vous avez bien mi un mot de passe root à mysql ?

sous linux:

Code : Tout sélectionner

mysqladmin -u root password "votrenouveaupasse"
sans les guillemets.

pour vérifier:

Code : Tout sélectionner

mysql -u root -p
ImageUNIX foreverImage
Avant toute demande de support, vérifiez votre fichier error.log Apache.
----------------------------------------

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » dim. 28 janv. 2007, 13:47

WAMP = windows ;)

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » dim. 28 janv. 2007, 13:51

Evolution a écrit :WAMP = windows ;)

La commande est identique sous Windows.. :wink:

Celeborn
Nouveau membre
Messages : 2
Inscription : dim. 28 janv. 2007, 0:48

Messagepar Celeborn » dim. 28 janv. 2007, 17:29

apparement le probleme c'est reglé tout seul en redemarrant le PC °° merci quand meme pour vos reponses^^


Revenir vers « PHP »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité