[VirtualHosts] Soucis de configuration

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

Teteve
Nouveau membre
Messages : 1
Inscription : jeu. 23 août 2007, 15:39

[VirtualHosts] Soucis de configuration

Messagepar Teteve » jeu. 23 août 2007, 18:45

Bonjour à tous,

J'expose tout d'abord ma config, et ensuite les soucis qui en résultent...
J'ai un serveur sur lequel tourne Bind9 et Apache2. Je suis le déposant de mon nom de domaine exemple.fr
Je souhaiterai faire deux sites : http://www.exemple.fr et http://www.site2.exemple.fr
J'ai crée deux repertoires : /opt/www/exemple et /opt/www/site2, chacun contenant un fichier index.html

dans le répertoire /etc/apache2/sites-available j'ai crée les fichiers suivants (default est celui existant par defaut) :

default :

Code : Tout sélectionner

NameVirtualHost *
<VirtualHost *>
   ServerAdmin webmaster@localhost
#   ServerName www.exemple.fr
   DocumentRoot /opt/www/exemple/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /opt/www/exemple/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # RedirectMatch ^/$ http://www.exemple.fr
   </Directory>
</VirtualHost >


http://www.exemple.fr.conf :

Code : Tout sélectionner

NameVirtualHost www.exemple.fr
<VirtualHost www.exemple.fr>
   ServerAdmin webmaster@localhost
   ServerName www.exemple.fr
   DocumentRoot /opt/www/exemple/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /opt/www/exemple/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # RedirectMatch ^/$ http://www.exemple.fr
   </Directory>
</VirtualHost>


http://www.site2.exemple.fr.conf :

Code : Tout sélectionner

NameVirtualHost www.site2.exemple.fr
<VirtualHost www.site2.exemple.fr>
   ServerAdmin webmaster@localhost
   ServerName www.site2.exemplefr
   DocumentRoot /opt/www/site2/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /opt/www/site2/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # RedirectMatch ^/$ http://www.exemple.fr
   </Directory>
</VirtualHost>


J'ai ensuite crée un lien symbolique de ces fichers dans le dossier /etc/apache2/sites-enabled/ :
000-default
001-www.exemple.fr
001-www.site2.exemple.fr

Les soucis :

Mais lorsque je redémarre apache, il me renvoie l'erreur suivante :
[warn] NameVirtualHost http://www.site2.exemple.fr:0 has no VirtualHosts

Ensuite, je voudrais qu'en tapant http://exemple.fr comme URL, on soit automatiquement redirigé sur http://www.exemple.fr, alors que pour l'instant les deux URLs affichent la même page.
Idem pour site2 bien sûr !!

Si vous vous sentez inspirés par ces soucis...
Merci d'avance
Teteve
Le plus intelligent est celui qui sait qu'il ne sait pas...

Avatar de l’utilisateur
remifedora
Membre avancé
Membre avancé
Messages : 94
Inscription : mar. 27 févr. 2007, 14:00
Localisation : Champagne
Contact :

Messagepar remifedora » sam. 25 août 2007, 12:36

Uniquement dans le premier fichier (000-default)

Code : Tout sélectionner

NameVirtualHost *:80

Et dans tous les fichiers définissant un hôte (00*)

Code : Tout sélectionner

<VirtualHost *:80>


Ces directives permettent de définir sur quelle adresse/port se fait la virtualisation, donc il faut une adresse (ou * pour toutes les adresse). Le nom est uniquement indiqué dans le ServerName.

Pour vérifier ta configuration

Code : Tout sélectionner

httpd -S


A+
Des RPM LAMP pour Fedora / RHEL / CentOS sur http://rpms.famillecollet.com/


Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités