Htaccess ignauré...

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

Avatar de l’utilisateur
M@T
Nouveau membre
Messages : 5
Inscription : mar. 26 avr. 2005, 15:15
Localisation : Lille, Nord, France, Terre
Contact :

Messagepar M@T » jeu. 28 avr. 2005, 9:53

Bonjour à tous !

Voila j'ai installé il y a qq jours mon premier serveur apache B) Hier soir, j'me suis lancé pour PHP 5.0.4 en installation manuel et en module Dll d'Apache (Pas en CGI). J'ai utilisé le fichier "php.ini-recommended" pour sa config avec juste la prise en charge d'une extention en plus...

Tout marche du premier coup, cool... :)
Mais après quelques heures de bidouile...
Pas moyen de protéger l'accés à un répertoire :(

Code : Tout sélectionner

AuthType Basic
AuthName "Acces Securisé"
AuthUserFile D:/WWW/pwd/.htpasswd
Require user mat


Il ne se passe absolument rien quand j'ouvre le répertoire, je vois tout et je télécharge... J'ai fait plein d'essais (guillemets, sans guillemets, liens absolu/relatif, cryptage différent, nom différent, etc) mais je sèche un peu là... :unsure:

Qq'un a-t-il une idée ? Sinon peut-on me donner la technique sécuriser directement dans le httpd.conf d'Apache ?

Merci d'avance !

PS: Merci à xgarreau pour le conseil sur JBC Explorer
C'est exactement ce que je cherchais mais en mieux :D
A+, M@T

Avatar de l’utilisateur
MistyFlip
Nouveau membre
Messages : 7
Inscription : sam. 16 avr. 2005, 0:22
Contact :

Messagepar MistyFlip » ven. 29 avr. 2005, 20:19

Salut !!

Est-ce que t'as modifié le httpd.conf d'Apache avant de faire tes fichiers .htaccess ?

Au cas où ça ne serait pas fait, ajoute une ligne de ce type à la fin de ton httpd.conf :

Code : Tout sélectionner

<Directory "CHEMIN">
AllowOverride FileInfo AuthConfig
Options Indexes
</Directory>

Le CHEMIN doit être tapé de la manière suivante :
C:\www\répertoire_protégé
En fait c'est ce que tu met à coté du AllowOverride qui est important :
FileInfo = pour les pages d'erreur personnalisées
All = acces autorisé pour tous
None = pour personne
AuthConfig = demande le mot de passe

et ton lien vers le fichier mot de passe peut ressembler à ça (chez moi ca marche...) :
C:\répertoire_password\.htpasswd

Bonne chance !!

<span style='color:green'>/Up
En fait je crois pas que la ligne de code soit indispensable...
Vérifie quand meme
/Up</span>

Avatar de l’utilisateur
M@T
Nouveau membre
Messages : 5
Inscription : mar. 26 avr. 2005, 15:15
Localisation : Lille, Nord, France, Terre
Contact :

Messagepar M@T » sam. 07 mai 2005, 19:15

Ben nan, rien à faire... G laissé le truc un peu de coté, mais je m'y suis remis, et malgrés moultes essais :(

Voici mon HTTPD (sans icon, language & charset):

Code : Tout sélectionner

ServerRoot "C:/Program Files/Apache/Apache2"
PidFile logs/httpd.pid
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15

<IfModule mpm_winnt.c>
ThreadsPerChild 250
MaxRequestsPerChild  0
</IfModule>

Listen 80

LoadModule access_module modules/mod_access.so
LoadModule actions_module modules/mod_actions.so
LoadModule alias_module modules/mod_alias.so
LoadModule asis_module modules/mod_asis.so
LoadModule auth_module modules/mod_auth.so
#LoadModule auth_anon_module modules/mod_auth_anon.so
#LoadModule auth_dbm_module modules/mod_auth_dbm.so
#LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule cgi_module modules/mod_cgi.so
#LoadModule dav_module modules/mod_dav.so
#LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dir_module modules/mod_dir.so
LoadModule env_module modules/mod_env.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule file_cache_module modules/mod_file_cache.so
#LoadModule headers_module modules/mod_headers.so
LoadModule imap_module modules/mod_imap.so
LoadModule include_module modules/mod_include.so
#LoadModule info_module modules/mod_info.so
LoadModule isapi_module modules/mod_isapi.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule mime_module modules/mod_mime.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule proxy_module modules/mod_proxy.so
#LoadModule proxy_connect_module modules/mod_proxy_connect.so
#LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule negotiation_module modules/mod_negotiation.so
#LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
#LoadModule status_module modules/mod_status.so
#LoadModule unique_id_module modules/mod_unique_id.so
LoadModule userdir_module modules/mod_userdir.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so

LoadModule php5_module "C:/Program Files/php-5.0.4-Win32/php5apache2.dll"
AddType application/x-httpd-php .php
PHPIniDir "C:/Program Files/php-5.0.4-Win32"

ServerAdmin admin@x.x.x.x
ServerName x.x.x.x:80

UseCanonicalName Off

DocumentRoot "D:/WWW"

<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>

<Directory "D:/WWW">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

UserDir "My Documents/My Website"
DirectoryIndex index.html index.php
AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>

TypesConfig conf/mime.types

DefaultType text/plain
<IfModule mod_mime_magic.c>
    MIMEMagicFile conf/magic
</IfModule>
HostnameLookups Off

ErrorLog logs/error.log
LogLevel warn
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

CustomLog logs/access.log common
ServerTokens Full
ServerSignature On

Alias /icons/ "C:/Program Files/Apache/Apache2/icons/"

<Directory "C:/Program Files/Apache/Apache2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

<Directory "C:/Program Files/Apache/Apache2/manual">
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

    <Files *.html>
        SetHandler type-map
    </Files>

    SetEnvIf Request_URI ^/manual/(de|en|es|fr|ja|ko|ru)/ prefer-language=$1
    RedirectMatch 301 ^/manual(?:/(de|en|es|fr|ja|ko|ru)){2,}(/.*)?$ /manual/$1$2
</Directory>

ScriptAlias /cgi-bin/ "C:/Program Files/Apache/Apache2/cgi-bin/"
<Directory "C:/Program Files/Apache/Apache2/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>
IndexOptions FancyIndexing VersionSort


ReadmeName README.html
HeaderName HEADER.html
IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t


BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0

BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully

<IfModule mod_ssl.c>
    Include conf/ssl.conf
</IfModule>

<Directory "D:/WWW/Photos/21_04_2005/">
AllowOverride FileInfo AuthConfig
Options Indexes
</Directory>



Quelle est mon erreur ?

Sinon, petite question, ya t'il caractère ou une formule magique qui pointe la racine du serveur sous Windows, car comme vous avez pu le constater, je mets toujours le chemin complet....
A+, M@T

Avatar de l’utilisateur
darkin
Membre
Membre
Messages : 12
Inscription : jeu. 14 avr. 2005, 20:55

Messagepar darkin » sam. 07 mai 2005, 20:04

moi le probleme c'est que le serveur fait comme si il n'y avait pas de fichier .htaccess a la raccine de mon site il fait comme si il y en avait pas... donc est ce que quelqu'un pourai m'expliquer comment configurer mon serveur pour qu'il prenn en compte les fichiers .htaccess present dans les sites web... si possible merci de m'aider tres clairement car je suis vraimant nul...
merci d'avance

Avatar de l’utilisateur
darkin
Membre
Membre
Messages : 12
Inscription : jeu. 14 avr. 2005, 20:55

Messagepar darkin » sam. 07 mai 2005, 20:43

j'ai peut etre touvé ou est ton pb :

Code : Tout sélectionner

<Directory />
   Options FollowSymLinks
   AllowOverride None
</Directory>

<Directory "D:/WWW">
   Options Indexes FollowSymLinks
   AllowOverride None
   Order allow,deny
   Allow from all
</Directory>

a cette endroit remplace les none par des all ce qui donnera :

Code : Tout sélectionner

<Directory />
   Options FollowSymLinks
   AllowOverride All
</Directory>

<Directory "D:/WWW">
   Options Indexes FollowSymLinks
   AllowOverride All
   Order allow,deny
   Allow from all
</Directory>

fait moi signe si ça fonctionne s'il te plait :unsure:


Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités