Allow from domaine

Questions sur la configuration d'Apache, httpd.conf, et les différents modules.

Modérateur : Modérateurs

houpdelta
Nouveau membre
Messages : 3
Inscription : lun. 31 oct. 2011, 18:26

Allow from domaine

Messagepar houpdelta » jeu. 12 janv. 2012, 22:31

Bonjour,

Je me prends la tête :( , j'aurai besoin de sécuriser un accès. Par contre je pense que c'est possible , mais pas sur du tout.

Je m'explique , j'ai awstats et je voudrais le visualiser au travers d'une iframe sur mon domaine. Mais je ne veux pas que l'url de l'iframe soit accessible en directe sans passer par le domaine.

Voici le code de la page par laquelle j’accède : http://mon.domaine

Code : Tout sélectionner

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
</head>
<body>
<div id="conteneur">
    <div id="gauche">       
    </div>
        <div class="zone">
   <IFRAME src="http://www.awast.home/stats/awstats.pl?config=www.mon.sous.domaine" width="99%" height="100%" ></IFRAME>   
       </div>
</div>
</body>
</html>


Jusque là pas de souci, j'affiche bien ma page avec les données awstats.

J'ai donc essayer un allow from mon.domaine dans mon virtualhost pour brider l'accès.
Et que personne ne puisse accéder directement par "http://www.awast.home/stats/awstats.pl?config=www.mon.sous.domaine".

Code : Tout sélectionner


<VirtualHost *:80>   
   ServerName awast.home
   ServerAlias www.awast.home

Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"

ScriptAlias /stats /usr/lib/cgi-bin/awstats.pl

# mêmes paramètres que dans awstats.*.conf
<Directory /usr/lib/cgi-bin/> 
  #DirectoryIndex awstats.pl
  UseCanonicalName off
#  AuthName "Statistiques awstats"
#  AuthType Basic
#  Require valid-user
#  AuthUserFile /che/min/.passwdstats
  Options +ExecCGI
  AllowOverride None
  Order Deny,allow
Deny from all
  Allow from [color=#4040FF]mon.domaine[/color]
</Directory>
</VirtualHost>


Mais rien ni fait , mon iframe reste forbidden.

Si quelqu’un à une idée , ou une autre piste pour configurer le directory, je suis preneur.

Merci.

Revenir vers « Configuration »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité