Apache linux dérrière passerelle XP...

Vous voulez configurer un réseau derrière un routeur, vous voulez protéger votre serveur des attaques ? C'est ici qu'on en parle.

Modérateur : Modérateurs

Diablo483

Messagepar Diablo483 » ven. 03 sept. 2004, 19:11

Salut,
j'ai une debian 3.1 (unstable) avec un serveur apache 2.0.50, je me connectes en ethernet par DHCP sur une passerelle XP (pas mon pc), j'aimerais que lorsque l'on rentre l'adresse IP de la passerelle on soit sur mon serveur apache, j'ai donc fait pas mal de recherche sur le net, je suis allé dans configuration de la connection internet, dans les services j'ai mis serveur Web, j'ai rentré mon IP...je suis allé dans ICMP et j'ai activé la redirection des ports, mais le problème c'est que ça ne marche pas.... :(
Quand je mets l'adresse Ip de la passerelle dans le navigateur web, ça me dit connection refusée...
Merci d'avance pour vos réponses!

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » ven. 03 sept. 2004, 20:14

il faut metre l'adresse ip de la machine unix (ou son nom d'hôte)
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Guest

Messagepar Guest » ven. 03 sept. 2004, 20:30

ba dans la configuration j'ai mis l'IP de mon Linux... :(

Avatar de l’utilisateur
Guide_Gnu
Pilier de forum
Pilier de forum
Messages : 1010
Inscription : dim. 07 mars 2004, 17:37
Localisation : Quelques part dans Level3
Contact :

Messagepar Guide_Gnu » ven. 03 sept. 2004, 20:38

essaye le nom d'hôte Linux (chez moi sa fonctione que ainsi :( )
6 ans de serveurs dédiers.
1 ré-installations (vive Gentoo..).
Plus de 10To échanger sur le web !

Diablo483

Messagepar Diablo483 » ven. 03 sept. 2004, 20:43

ça ne marche pas non plus, le firewall XP est activé, ça peut venir de ça?

Avatar de l’utilisateur
apis
Pilier de forum
Pilier de forum
Messages : 1107
Inscription : sam. 21 févr. 2004, 14:50
Localisation : Lyon
Contact :

Messagepar apis » ven. 03 sept. 2004, 20:47

oui, ça peut venir de la. il faut alors que tu ouvre le port 80, si tu n'as pas changé le port d'écoute d'apache


mais, tu t'es pas trompé de forum ?? :huh:
Nekralium Admin: Au jour du jugement, la plume du savant pèsera autant que l'épée du guerrier.

Diablo483

Messagepar Diablo483 » ven. 03 sept. 2004, 20:56

Ha oui désolé merci...

routeur!

Messagepar routeur! » dim. 03 oct. 2004, 15:18

Tu dois configurer le routeur :

généralement <a href='http://192.168.0.1' target='_blank'>http://192.168.0.1</a> dans la barre d'adresse

trouver la page ou autoriser le serveur

remplir les param (port 80, enabled, ip locale du serveur (192.168.1.2, par ex)

comme ça quand on demande l'adresse ip du routeur, il sait qu'il doit rediriger le navigateur vers l'ip locale (soit le serveur)

attention si tu veux accéder aux pages du serveur depuis d'autres pc du réseau, ne pas taper l'adresse du routeur, mais bien l'adresse locale du serveur (192.168.1.2, par ex)

bill

Messagepar bill » dim. 03 oct. 2004, 15:42

Bonjour
je crois que vous faites une erreur
le fait de tapper la passerelle ca vous permet de rentrer ds la config du routeur par exemple
par rapport à votre question il va y avoir un conflit et ca ne passera pas d'ailleurs
on ne peut pas pointer le serveur sur la paserelle

peut etre mais c'est pas sur mais les chances sont moindres par ds la config du routeur vous prenez la paserelle pour le serveur mais specifier le port j'espere que ca marche


Revenir vers « Routeurs et firewalls »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité