configuration de awstats... J'y arrive pas !

Parlez ici des outils utilisables conjointement à Apache (analyseurs de logs... etc).

Modérateur : Modérateurs

jabba
Membre
Membre
Messages : 17
Inscription : jeu. 16 nov. 2006, 21:17

configuration de awstats... J'y arrive pas !

Messagepar jabba » mer. 20 déc. 2006, 12:58

Bonjour,

C'est censé être simple à configurer et pourtant, j'y arrive pas...

Code : Tout sélectionner

root@sumega01lpro # perl awstats.pl -config=sumega01lpro -update
Update for config "/etc/awstats/awstats.sumega01lpro.conf"
With data in log file "/var/apache2/logs/access_log"...
Phase 1 : First bypass old records, searching new record...
Searching new records from beginning of log file...
AWStats did not find any valid log lines that match your LogFormat parameter, in the 50th first non commented lines read of your log.
Your log file /var/apache2/logs/access_log must have a bad format or LogFormat parameter setup does not match this format.
Your AWStats LogFormat parameter is:
%host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot
This means each line in your web server log file need to have the following personalized log format:
%host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot
And this is an example of records AWStats found in your log file (the record number 50 in your log):
172.16.12.156 - - [16/Nov/2006:12:01:11 +0100] "GET /standard/genr.gif HTTP/1.1" 200 990
Setup ('/etc/awstats/awstats.sumega01lpro.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).
root@sumega01lpro #


J'ai suivi (bêtement ... ?) la doc d'installation, voici mon fichier de conf pour le site en question:

Code : Tout sélectionner

#LogFile="/var/log/httpd/mylog.log"
LogFile="/var/apache2/logs/access_log"

LogFormat=1
LogFormat="%host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot"

SiteDomain="sumega01lpro"

EnableLockForUpdate=1

AuthenticatedUsersNotCaseSensitive=1

DebugMessages=1


Mon fichier httpd.conf:

Code : Tout sélectionner

#
# Directives to allow use of AWStats as a CGI
#
Alias /awstatsclasses "/opt/awstats-6.4/wwwroot/classes/"
Alias /awstatscss "/opt/awstats-6.4/wwwroot/css/"
Alias /awstatsicons "/opt/awstats-6.4/wwwroot/icon/"
ScriptAlias /awstats/ "/opt/awstats-6.4/wwwroot/cgi-bin/"

#
# This is to permit URL access to scripts/files in AWStats directory.
#
<Directory "/opt/awstats-6.4/wwwroot">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

<Directory /opt/awstats-6.4/wwwroot/cgi-bin>
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>


Le format d'une ligne du fichiers de logs d'accès de apache:

Code : Tout sélectionner

172.16.12.156 - - [19/Dec/2006:10:35:46 +0100] "GET /standard/ws_svg.js HTTP/1.1" 200 17129
172.16.12.156 - - [19/Dec/2006:10:35:46 +0100] "GET /images/e235e587430e0774_iimage/status3.png HTTP/1.1" 200 209


Les droits sont à 755 sur toute l'arborescence de awstats.
Mon installation tourne en Solaris 9 et apache 2.0.55

L'erreur indique un problème au niveau du LogFormat déclaré dans le fichier de conf de awstats mais je ne vois pas comment faire correspondre avec les logs crachés par apache. :-(
Si vous avez une idée, ca me dépannerait beaucoup...
En attendant je vais me retaper la doc de awstat...

Merci

Jean

Avatar de l’utilisateur
bgarnier
Membre ancien
Membre ancien
Messages : 180
Inscription : mer. 04 févr. 2004, 12:45
Localisation : Ile de france

Messagepar bgarnier » jeu. 21 déc. 2006, 11:43

Bonjour,

Vous devez dans ce cas ( absence de la doc de awstat ) modifier la directive LogFomat du fichier de configuration apache en vous basant sur le contenu de la page suivante :

http://httpd.apache.org/docs/2.0/mod/mod_log_config.html#formats

cordialement benoit


Revenir vers « Outils liés à Apache »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité