compiler mod_ldap

Questions sur le développement d'Apache et de ses modules.

Modérateur : Modérateurs

Avatar de l’utilisateur
cedric92
Nouveau membre
Messages : 5
Inscription : lun. 26 juin 2006, 16:39

Messagepar cedric92 » jeu. 29 juin 2006, 17:07

Bonjour a tous,

Ayant installer deja installer apache2, j'ai tapé la commande:

apxs -c util_ldap.c

pour pouvoir installer le module mod_ldap.
Le message d'erreur suivant apparait:
"util_ldap.c:81: #error mod_ldap requires APR-util to have LDAP support built in'

j'ai essayé avec

apxs -c apr-util.c -I /usr/local/apr-util/include -L/usr/local/apr-util/lib

mais j'ai toujours le meme probleme :(

Quelqu'un a une idée? :rolleyes:

Avatar de l’utilisateur
dexmon
Gourou
Gourou
Messages : 793
Inscription : sam. 18 juin 2005, 9:55
Localisation : /usr/local/apache
Contact :

Messagepar dexmon » mar. 05 déc. 2006, 8:32

j'ai aussi la même erreur en essayant l'auth_ldap, cette question revien souvent on dirait, faudrait que les développeurs se penchent un peu dessus.
tu peux essayer d'installer ceci : http://apache.belnet.be/apr/apr-0.9.13.tar.gz

Sinon j'ai trouvé ça : http://marc.theaimsgroup.com/?l=apache- ... 131564&w=2
Dernière édition par dexmon le mar. 05 déc. 2006, 9:41, édité 1 fois.

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » mar. 05 déc. 2006, 8:47

Sur ma distribution j'ai dû installer le RPM de apr-util, facilement trouvable
Laquelle avez-vous ?

Avatar de l’utilisateur
dexmon
Gourou
Gourou
Messages : 793
Inscription : sam. 18 juin 2005, 9:55
Localisation : /usr/local/apache
Contact :

Messagepar dexmon » mar. 05 déc. 2006, 9:43

Evolution a écrit :Sur ma distribution j'ai dû installer le RPM de apr-util, facilement trouvable
Laquelle avez-vous ?


Ben en fait je suis sur Debian Sarge et j'essai de compiler apache-2.0.59 avec le mod_auth_ldap et il me met une erreur comme quoi il lui faut le apr-util.
Mais lje l'ai installé et je lui ai indiqué le chemin dans la configure mais rien à faire.
J'ai ça :

Code : Tout sélectionner

error: Cannot use an external APR with the bundled APR-util

Evolution
Conseiller
Conseiller
Messages : 3032
Inscription : lun. 05 janv. 2004, 18:56
Localisation : Lyon

Messagepar Evolution » mar. 05 déc. 2006, 10:07

vous avez apparemment tenté d'installer un APR externe, alors qu'il lui faut seulement un apr-util externe
le APR utilisé est celui d'Apache normalement

Avatar de l’utilisateur
dexmon
Gourou
Gourou
Messages : 793
Inscription : sam. 18 juin 2005, 9:55
Localisation : /usr/local/apache
Contact :

Messagepar dexmon » mar. 05 déc. 2006, 10:25

Evolution a écrit :vous avez apparemment tenté d'installer un APR externe, alors qu'il lui faut seulement un apr-util externe
le APR utilisé est celui d'Apache normalement


celui qui se trouve dans les sources d'apache ou celui qui est installé ?

[edit]J'ai compris, il faut installer celui qui se trouve dans les sources


Revenir vers « Développement Apache »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité