Config module module_config et non per_dir_config

Questions sur le développement d'Apache et de ses modules.

Modérateur : Modérateurs

Avatar de l’utilisateur
fex
Nouveau membre
Messages : 5
Inscription : lun. 01 août 2005, 21:26

Messagepar fex » mer. 10 août 2005, 18:20

Bonjour,

J'ai écrit un petit module Apache qui devrait permettre de faire un mapping certificat X509 et userid via un annuaire LDAP.

J'utilise aussi Apache pour faire du reverse proxy. Et c'est là où cela se complique, car le mode proxy activé, Apache n'appelle plus mon module. Pkoi ?

Je pense que mon module est déclenché par un accès fichier (ou repértoire), et qu'en reverse proxy pas d'accès fichier.

J'ai pourtant activer le module en précisant AP_MODULE_DECLARE_DATA avec des fonctions de création par directory mais aussi par server_config.

Y a qq'un qui pourrais m'aider ?

Merci

Avatar de l’utilisateur
fex
Nouveau membre
Messages : 5
Inscription : lun. 01 août 2005, 21:26

Messagepar fex » mer. 10 août 2005, 22:23

Résolu :

C'était du à un problème d'enchainement de chargement....

Il faut simplement que le nouveau module soit chargé et exécuté avant mod_proxy.

Chargé avant : placé avant avec LoadModule
Exécuté avant : Handler avec APR_HOOK_FIRST

J'espère que ca pourrait aider d'autres personnes

A bientot


David

Avatar de l’utilisateur
xgarreau
Pilier de forum
Pilier de forum
Messages : 1747
Inscription : jeu. 08 juil. 2004, 9:41
Localisation : ZazouLand @ La Rochelle
Contact :

Messagepar xgarreau » jeu. 11 août 2005, 10:42

Merci, c'est vrai qu'on manque de "développeurs apache" sur le forum ...

Ah, si on avait un tuto introductif ... :unsure:

a+
ZazouMiniWebServer : votre serveur web PHP/MySQL/SQLite sur votre pc, cd ou clé usb
Image
http://www.zmws.com/


Revenir vers « Développement Apache »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité