Bug authentification Tomcat 5.5

Discussions sur le développement de JSP, servlets, et Java en général.

Modérateur : Modérateurs

vlaurent31
Nouveau membre
Messages : 1
Inscription : jeu. 27 sept. 2007, 16:05

Bug authentification Tomcat 5.5

Messagepar vlaurent31 » jeu. 27 sept. 2007, 16:37

Bonjour,

J'ai un projet J2EE sous Tomcat 5.5 et j'ai un problème qui apparait après un certain d'utilisation (en gros tous les matins).
J'utilise Realm et une authentification Form-Based.
Lorsque je tappe mon login et mot de passe sur le formulaire puis OK, je suis renvoyé vers une page totalement blanche (aussi bien si le mot de passe est bon ou mauvais). L'url qui apparait dans la barre d'adresse est "http://server/webapp/j_security_check".

L'authentification fonctionne très bien pendant quelque temps et le matin lorsque je vais tester l'appli, celle-ci ne fonctionne plus (uniquement les servlets protégées posent problème). Je suis alors obligé de recharger le web.xml pour que le fonctionnement devienne à nouveau normal.

Code de web.xml :

Code : Tout sélectionner

   <login-config>
     <auth-method>FORM</auth-method>
     <form-login-config>
       <form-login-page>/login.jsp</form-login-page>
       <form-error-page>/ErrorPage.jsp</form-error-page>
     </form-login-config>
   </login-config>



Code du formulaire :

Code : Tout sélectionner

<form method="POST" action="j_security_check">
  <input type="text" name="j_username" size="30" maxlength="45" />
  <input type="password" name="j_password" size="30" maxlength="45"
/>
  <input type="submit"  value="Submit"/>
</form>

Revenir vers « Java »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités